Forums » Support

Can't reach a group

    • 6 posts
    September 14, 2017 9:10 PM EDT

    Hello~ I have been trying to get on the Skyrim character building group and it just times out on me saying:

    This page isn’t working didn’t send any data.

    I would really like to get on and I would appreciate any help given to me. Thank you in advance~
    • 700 posts
    September 14, 2017 9:14 PM EDT

    Sorry to hear you're having trouble, Mace. Are you using Chrome by chance?

    • 6 posts
    September 14, 2017 9:16 PM EDT

    Yes I am.

    • 700 posts
    September 14, 2017 9:18 PM EDT

    It look like the error you're encountering is most likely on your end. Check out this page, try what it says, and let me know if you're able to access the group afterwards. 

    • 6 posts
    September 15, 2017 2:59 AM EDT

    Well, I tried and for a long while it wouldn't even let me get on the site in general. I still can't reach the group.

    • 77 posts
    September 15, 2017 2:36 PM EDT

    Hey Mace, sorry your having trouble.  It seems like you are able to access teh rest of the site just not that specific group page correct?  If you were looking to browse builds here is a link to the archives hopefully that works for you.  If you were trying to do something else let me know and I will try to help.

    • 6 posts
    September 15, 2017 2:47 PM EDT
    I was actually able to reach that part after googling it but the links wouldn't lead to anything except the death screen...
    • 77 posts
    September 15, 2017 4:20 PM EDT

    So even my link to the archives didn't work?  Sorry man I know that sometimes there is a load time issue with Skyrim CB's group page my hope was that the link would at least let you access the builds.  It works for me and all the archive links work for me as well so I think Legion is right, it does sound like something is screwy on your end.


    • 6 posts
    September 15, 2017 5:31 PM EDT
    I tried all that I could but it gave me nothing in return. But at least it works on my phone~