Forums » Elder Scrolls

Funniest/Stupidest thing that happened to you while playing an E

    • 64 posts
    April 29, 2015 2:45 PM EDT

    It's been 3 years since I got Skyrim and I've seen all the serious stuff and all the Youtube clips of funny glitches. Now I want to hear some more hilarious stories about your experiences (I know this has probably been done before).

    • 10 posts
    April 29, 2015 2:47 PM EDT

    Well it would have to be trying to kill greybeards and getting shouted of the mountain or playing tag with a giant.

    • 207 posts
    April 29, 2015 2:57 PM EDT

    Using the action command to touch a dead stag on a hunters working table and it starts vibrating.

    A guard falling of the sky.

    Getting kill cammed by a dragon... trough a solid pillar.

    • 64 posts
    April 29, 2015 3:21 PM EDT

    I had Orthorn steal my kill cam once. What else...

    A werewolf walked up to me and told me to go see Majni... in werewolf form... in the middle of Raven Rock.

    A thief came up to me and tried to rob me while I was in werewolf form. "Do I look like I have any money?"

  • Tim
    • 92 posts
    April 29, 2015 4:49 PM EDT
    Falling deaths in general.
    One of the Greybeards was chilling up past the gate where you learn WW sprint and would Fus Ro Dah whenever I activated him, so I stood in front and got rag dolled off the mountain :D
    • 66 posts
    April 29, 2015 4:50 PM EDT

    I was running away from Windhelm with a bunch of guards in hot pursuit. I stole a horse from the stables then preceded to immediately crash into into the travel cart. The game glitched and launched me about 500 feet through the air and into the river. I was able to swim to safety and avoid hypothermia by dancing around a bonfire with a giant trying to squash me.

    • 485 posts
    April 29, 2015 4:57 PM EDT
    Got myself stuck in a corner between a wall and a rock formation. Unable to escape this glitchy trap, I was hacked to death by the squad of bandits I pissed off along the way.
    • 24 posts
    April 29, 2015 5:06 PM EDT
    The first time I did the Diplomatic Immunity quest, I didn't understand the directions so I gave away all my gear. So my Nord is running around in his loin cloth and I'm thinking this is stupid. Here I am in my underwear and nobody seems to care, but hey that's Skyrim. Anyways a dragon attacks. So I had to fight him without clothes or weapons. With the help of the local authorities and shouts I was able to bring him down and punch him to death.
    • 457 posts
    April 29, 2015 6:07 PM EDT

    I had a dragon skeleton follow me for almost an entire game. I'd get out of a dungeon or cave, and the thing would fall right out of the sky in front of me and start jiggling. I'd leave the thing far behind me to visit a city, exit the city through the front gate, and the blasted thing would drop out of the sky in front of me again... it got kind of unsettling to be stalked by a dead dragon over and over again xD

    There has also been:

    • Skywalking mammoths.
    • Vex in a box:

    • Landing on top of a character while in sneak mode and the character could not tell that I was standing on him

    It's been a great three and a half years ;D

    • 1467 posts
    April 29, 2015 7:01 PM EDT

    I dunno. I got attacked b a Dragon on the Diplomatic Immunity Quest, in the main courtyard...Let's just say it didn't go to well for poor defenseless me. (I will note that you cannot shout, wield weapons or use Powers at this point so yeah, lot's of running around with the Carriage Drives)

    That one time I fell through the map and managed an ever-lasting loop of falling and being teleported back up, good times.

    • 33 posts
    April 29, 2015 7:06 PM EDT
    The thieves guild appears to be very glitchy. I remember this one time I was just going to talk to tonilia to get my armor, and I had the dog from markaeth with me and I was talking to tonilia and suddenly she started attacking my dog, she killed my dog and then, while she was talking about nothing being free she ran into the water and died , I assume she drowned. I never got my armor and yet nobody acted like anything happened and it didn't mess up any quests. Weird event.
    • 966 posts
    April 29, 2015 7:14 PM EDT

    I got killed by a mudcrab in Morrowind, Oblivion and Skyrim. The only reason it didn't happen in Daggerfall was because there were not mudcrabs. Still got killed by a rat. I'm good at games, I promise..

  • April 29, 2015 7:21 PM EDT

    I know that feel, bro. I got glitched into a rock formation in the middle of a river while dodging a mudcrab. So I was spinning around like an idiot while getting my health slowly whittled away by a giant crab. My brother was watching at the time, and he still won't let me live it down.

    • 966 posts
    April 29, 2015 7:27 PM EDT

    Atleast you got glitched. First time I played Morrowind I was like 7-8 years old, I tried punching the mudcrab but it just wouldn't die

    • 485 posts
    April 29, 2015 7:37 PM EDT

    I was once a sliver away from killing a dragon only to have it dive down and grab me with its claws for an auto kill. 

  • Tim
    • 92 posts
    April 29, 2015 8:40 PM EDT
    Man, I had almost forgot about my skeletal dragon stalker! That happened to me a loooooooonnnnggggg time ago. And it was weird.
    • 1 posts
    April 29, 2015 10:30 PM EDT

    Enough said.
    • 168 posts
    April 29, 2015 10:49 PM EDT

    First time I found Pinewatch; here I was on my way to wherever it was I was trying to go to, and then I see this cabin in the forest, along the road. So, I walk up to it, and glance at the cart with leeks in it. I looked at the leek and I was like "Take leak, (lol)", and while I was 'avin a giggle' a large frostbite spider attacked me from behind and gave me a good jumpscare. Couldn't recreate that if I tried.

    Dealt with the spider easily, though. That was probably the funniest thing that happened that wasnt because of a bug or something to do with follower ai derping around. It was also on that same file I had gotten the candlestick mold stuck in my inventory, and couldn't remove it because I was not in the Thieves Guild and wasn't joining. My earlier files like that one always had quest items glued to my inventory because I didn't get the quest or wasnt going to do the quest because I wanted to explore.

    • 14 posts
    April 30, 2015 12:00 AM EDT
    One time when i entered solitude for the first time the execution glitched and the prisoner (forgot his name rogvir or somthing) flopped in the air and the guard captin guys body was glitched and was flat on the floor but his body was sliding on the ground back towards the castle, it was hilarious, then there was this other time in raven rock where the wearbears just walked up to me and didnt attack me they just followed me and stared at me im like "okay?" It was really creepy but at the same time awkwardly funny, also skywalking mammoths and somehow a dragur showed up in whiterun and qas just walking around.
  • April 30, 2015 1:45 AM EDT

    I once ran straight at a Legendary Dragon, on Expert Difficulty, with under 30 Health wearing only Leather Armour. Needless to say it didn't end well for me...

    • 2 posts
    April 30, 2015 5:42 AM EDT

    lydia got hit by a giants club and flew up into the air. i killed it then once that was over she landed... ALIVE!!!

    • 64 posts
    April 30, 2015 10:11 AM EDT

    That happened to me once. This is also why I never fight dragons in close combat (unless they're that weak)

    • 64 posts
    April 30, 2015 10:17 AM EDT

    Did you try to set something back in place?

  • April 30, 2015 11:50 AM EDT

    When the Companion Quest "Proving Honor",When I exited through the back,the mountain (Skyforge place)

    became HUGE  I was really startled because of that.

    • 32 posts
    April 30, 2015 2:13 PM EDT

    Before entering the Soul Cairn, after I handed her the ingredients, Serana crafted the juice, then...her clothes vanished...Nothing worked...reload, enable disable, and she was like "we should hurry, my mom's down there." I was like, "All the more reason to put on your damn clothes. "

    Turns out it was a follower mod problem.

    And never piss off Arniel, he looks like a feeble old guy, but once he's angry, boom!...Steel Battleaxe...